Importing Subcontractors from a CSV File

To access this utility, go to File > Import/ Export Data > Import Subcontractors from a CSV File.

 

1) Browse to the location of your Subcontractor CSV File

2) Select the required file and click 'Open'

3) Your subcontractor information will be displayed on screen. For each column, choose the subcontractor data it represents. Ignore any columns and uncheck any rows you do not wish to be imported

To assist with column selection, under 'Options', simply select 'Try and Match Columns to CSV Header Row Titles'. BrightPay will try and match as many columns as it can for you.



 

 

 

 

Please note: should you have subcontractor CSV files to import for more than one company e.g. you are moving a number of companies across from a previous software, simply instruct BrightPay to 'Remember Column Selections' under the 'Options' menu. BrightPay will subsequently remember the column selection used in the previous import when next importing a new subcontractor CSV file.

Alternatively, should you wish to reset your column selection, select 'Reset All Columns'.


 

4) Click Import to complete the import of your employee information.

 

Fields which can be imported into BrightPay using CSV file format are:

Trading Name

Unique Tax Reference (UTR)

Business Type

Person's first name (sole trader/ partner)

Person's middle name (sole trader/ partner)

Person's surname (sole trader/ partner)

National Insurance number (NINO

Company name

Company registration number (CRN)

Partnership name

Partnership UTR

Is VAT Registered

VAT registration number (VRN)

Tax payment status

Verification number

Verification date

Daily pay rate

Hourly pay rate

Works number

Department

Address Line 1

Address Line 2

Address Line 3

Address Line 4

Postcode

Email Address

Phone Number

Payment frequency

Payment method

Payment bank name

Payment bank branch

Payment sort code

Payment bank account name

Payment bank account number

Payment bank reference

Document password

Notes


Please note: if you have previously used CIS Assistant 2015-16, a CSV file can be created within the CIS Assistant software for importing into BrightPay:

 

  • Within CIS Assistant, select 'Utility > Create export file for BrightPay'



 

 

  • Click 'CSV File' and save your export file to a location of your choice e.g. to the Desktop

 

  • This export file can now be seamlessly imported into BrightPay by going  to File > Import/ Export Data > Import Subcontractors from a CSV File. 

Need help? Support is available at 0845 300 4304 or support@brightpay.co.uk.

Important Information for MAC UsersInstalling BrightPayImporting From The Previous Tax YearMoving to BrightPay from another payroll softwareEmployer DetailsEmployee DetailsProcessing PayrollPayroll CalendarPayslip TranslationsMaking Corrections to PayrollPre-paying an EmployeeScheduling Future PaymentsSwitching an Employee's Pay FrequencyRTICommon HMRC Error MessagesHMRC PaymentsAnalysisStartersLeaversStudent Loan DeductionsStatutory PaymentsPensionsAttachment of EarningsPayroll GivingDirectorsEmployee CalendarHolidaysTaxScottish Rate of Income Tax (SRIT)National InsuranceEmployment AllowanceNational Minimum Wage and National Living WageRates & Thresholds at a GlanceYear EndBacking Up/ Restoring Your PayrollBrightPay Licence Terms and ConditionsConstruction Industry Scheme (CIS)Ordering for The New Tax YearAutomatic EnrolmentBrightPay CloudExpenses & Benefits